Hello, Ubuntu!

本站操作系统更新为博主最喜欢的ubuntu操作系统了!

因为之前为了顺利建站,更多的考虑稳定性,没有把软件的时效性放在更高的优先级,因此网站建好后,wordpress提示后台环境版本太低。而之前建站稀里糊涂的,脑子里对最后的操作系统结构不是特别清晰。折腾半天也没把环境版本升上去。

昨天一咬牙一跺脚,直接重装操作系统,现在的服务器自己都感到清爽了。

在阿里云镜像里选择最新版本的ubuntu18.04 x64操作系统,然后下载运行lnmp1.6环境,按照提示安装mysql和php,当然都选择最新版本,一通绿字滚动(两个多小时),环境就建设好了。

这时候在浏览器里输入IP地址,就应该可以打开lnmp的页面,进入phpmyadmin,对mysql数据库进行设置,新建一个用户,勾选建立同名数据库,这个数据库就作为wordpress的数据库了。

再通过lnmp建立ftp服务,输入命令

lnmp ftp add

按照提示输入用户名、密码,网站的目录,很快就完成了安装。这时候就可以通过ftp访问服务器的网站目录,并上传文件了。

把wordpress5.4软件包上传到服务器网站目录下,通过浏览器访问wordpress的index.php文件,就可以设置安装wordpress了,输入刚才建立的wordpress数据库名称和用户名、密码,wordpress自己会完成安装。

进入安装完成的wordpress仪表盘,设置好域名等内容,网站基本就建好了。

最后,运行命令

lnmp ssl add

安装ssl安全认证,输入带www的域名和不带www的域名,一路默认或yes,在选择ssl模式时,选2

2: Use Let’s Encrypt to create SSL Certificate and Key

安装完成后,网站就可以通过https加密访问了。

问题

我的网站安装调试完成后,发布新文章时提示错误

错误信息:此响应不是合法的JSON响应

网上有一些解决方法,比如停用古腾堡编辑器、重装系统、重装wordpress等,感觉跟我的症状不匹配。耐心寻找后,找到一个解决方法,是更改伪静态地址。

把Wordpress后台的固定链接设置为朴素,也就是动态的,问题就得到了解决,可以发表文章了。

我产生这个问题的原因是因为安装了WP Super Cache插件,这个插件要求更改“固定链接”,改回来后,这个插件就无法工作了,但是影响暂时不大。最终放弃了这个插件。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据