mac系统python环境设置

问题

MAC下,系统默认python版本为2.7。虽然macOS一直在升级,但不知为何对内核内建的python却不与时俱进。在开发过程中需要导入的模块,Python2.7都不支持,所以必须安装最新版。在Python官方网站下载的包只是个idle,并不替换内核,因此,需要对内核进行更改。

安装conda

从网络下载conda,可以下载anaconda,也可以下载miniconda,如果是图形界面,操作简单,照着执行即可。
如果是脚本文件 .SH,就需要打开终端,运行

bash Anaconda2-4.3.1-MacOS-x86_64.sh

在安装过程中,会提示安装目[……]

继续阅读

第一篇

二十多年前,我还在大学,那时互联网刚刚进入人们的视野,我就有了做一个自己的网站的愿望。那时候自己看书学习HTML知识和命令,自己在记事本上写HTML命令,还是很有乐趣的。但是做了个功能单一、界面简单的网站后就不知该怎么办了。因为我只学了做网页,没搞懂怎么把网页放到互联网上去。而那时候国内也没有这么丰富多样的托管服务器之类的,对一个学生来说连最早的调制解调器也没有,上网都得去学校机房,押学生证、穿鞋套。因此玩了玩之后,也就打消了把自己的简陋网页放上网的想法。之后工作,虽然也动过做个人网站的念头,但一没时间,二没继续学习相关技术,也就作罢了。

时过境迁,我们从电脑单机[……]

继续阅读